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Disclaimer

Digital Dash EFI LLC makes no affiliations, representations, endorsements, sponsorships, or associations
with the Raspberry Pi Foundation or EFl Analytics.

Digital Dash EFI LLC makes no representations or warranties of any type with respect to the contents in
this manual. Digital Dash EFI LLC disclaims any implied warranties or fitness for any particular purpose.
Digital Dash EFI LLC is not liable for any errors contained within or for incidental or consequential damages
in connection with the supply, performance or use of the hardware and software or this manual.

Digital Dash EFI LLC reserves the right to revise this installation and user manual at any time, without
obligation to notify any person of revisions. As defined by the Magnuson-Moss warranty Act, do not install
any products or services unless you have the technical ability to properly set-up the entire vehicle to
compensate for the installation of those products or services. The necessary work and expertise needed
to install different products varies. Instructions, where provided, are given to assist in the installation only;
they are not a substitute for mechanical experience in setting up vehicles. Digital Dash EFI LLC is not
responsible for any personal or property damages caused by the installation of this product.

Warranty

Digital Dash EFI LLC makes every effort to ensure our products and services are of the highest quality and
standards. This warranty applies to the ORIGINAL PURCHASER of this product and covers only those
products exposed to normal use or service. Digital Dash EFI LLC warrants all merchandise manufactured
by Digital Dash EFI LLC against defects in workmanship or material for a period of six (6) months after the
date of purchase. This warranty does not apply to any product that has been damaged through alteration,
improper installation, mishandling, misuse, neglect, or accident. Any part or product found to be
defective after examination by Digital Dash EFI LLC will be repaired or replaced. Digital Dash EFI LLC
assumes no responsibility for loss of time, diagnosis, removal and/or installation labor, loss of vehicle use,
inconvenience or any other consequential expenses.

This Warranty is in lieu of all other expressed warranties or liabilities. Any implied warranties, including
any implied warranty of merchantability, shall be limited to the duration of this written warranty.

If you have any questions regarding warranty, please contact support at Digital Dash EFI LLC at
support@dd-efi.com.

WARNING: California’s Proposition 65 requires that a clear and visible warning be provided to consumers in California that have
the potential to expose them to various substances which may cause cancer, birth defects or other reproductive harm. Many of
the products of Digital Dash EFI LLC utilizes manufactured products from Aluminum, Plastics, and other standard materials. These
products can expose you to chemicals including lead, which is known to the State of California to cause cancer and birth defects
or other reproductive harm. For more information go to www.P65Warnings.ca.gov
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Installation of this product may void your manufacturer’s factory warranty.
Please install at your own risk as the dealer or service provider may wish to verify
the vehicles mileage/codes/service hours/etc. by connecting via diagnostic tool.

Digital Dash Kit (DD-EFI-12.3-DD)

Items Included:
e (1) DD-EFI 12.3” Digital Dash
e (1) Power Supply Connector
o Red-12V+ Battery
o Black—Ground
o Yellow —12V+ Ignition
o Blue —12V+ Door/Dome Light Trigger (Optional)
e (1) GPS Antenna
e (1) Quickstart Guide

Items NOT Included:

e TunerStudio MS/Ultra Registered License
e Wireless Keyboard & Mouse

o (ie: Logitech K400 Wireless keyboard and Built-in Touchpad)
e Serial to USB Cable

o Needed for MS1, MS2, Microsquirt Systems
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Features

The Digital Dash Kit is a fully programmable LCD dash display that connects your standalone ECU
(MS1/MS2/MS3) directly to your TunerStudio MS/Ultra tuning software via USB connection. Built-in
features include: boot-up splash screen video, customizable digital dashboard, and datalogger.

Dashboard Features

Below is a list of the common parameter’s users would like to be displayed via the dashboard of which is
being captured by your MS ECU. *Some items may need additional wiring/configuration to be displayed
on your dashboard.

e Engine RPM e Spark Timing

e Engine Coolant e MPG (Instant/Average)

e MAP e Shift Light

e MAT (Engine/Manifold Temperature) e *Qil Pressure

e Boost PSI & Vacuum e *Speedometer (GPS or digital input)
e Target AFR (Air Fuel Ratio) e *Fuel Level

e Actual AFR (Air Fuel Ratio) e *Gear Position

e Closed Loop Ildle Indicator e *Transmission Temperature

e Battery Voltage e Etc...

Power Supply Features

The built-in power supply is automatically activated by either the Door Switch/Dome Light Trigger
(Optional Blue Wire) or Vehicle Ignition Power is Active. The power supply is internally configured to
shutdown 30 minutes after Door Switch/Dome Light Trigger (Optional Blue Wire) or Vehicle Ignition Power
is Deactive.

e Pre-Programmed to 30 Minutes

e Low standby current draw of 4 mAh
o Won’t drain your vehicles battery

e Ignition sensing wire for turning ON/OFF computer
o Optional Door/Dome Light Trigger
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Hardware Installation

1. Remove the Vehicle’s Stock Instrument Cluster (if available)

2. Wire and Plug-in the Power Supply Connector:
» Red - 12V+ Battery
» Black — Ground
» Yellow — 12V+ Ignition
> Blue — 12V+ Door/Dome Light Trigger (Optional)

3. Install GPS Antenna
» The GPS Antenna needs to have access to the open sky
» The GPS Antenna is also weatherproof & magnetic, so it can be installed on the
exterior if desired

4. Install MS Tuning Cable to USB Port
» MS1, MS2, Microsquirt System will need a Serial to USB Cable

5. Optional: Plug in the USB Dongle for your Wireless Keyboard & Mouse

6. Mount the Digital Dash in its permanent location

If you are completely removing the stock instrument cluster a Jumper
Wire may need added to your instrument clusters wiring from the
Alternator Sensing/Excite Wire to your Ignition 12+ Wire.

The alternators sensing/excite wire in many vehicles are wired to your
battery indicator light. Removal of the instrument cluster may disconnect
your Alternator wiring, and will need to be reconnected. Failure to do so
my result in your alternator not charging. Make sure to either reinstall
the factory resistor from your instrument cluster or add a 2-Amp fuse
in-between the Jumper Wire.

WARNING: When mounting the Digital Dash do NOT cover the fan
holes on the back as this could lead to overheating.
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Software Configuration

Enabling Your TunerStudio MS/Ultra License

The Digital Dash utilizes the registered version of the EFI Analytics TunerStudio MS/Ultra software as your
tuning and dashboard display. To activate the tuning and dashboard features you need to use your
registration key from your TunerStudio MS/Ultra software.

1. Turn ON the Ignition to the Vehicle to start the boot-up of the digital dash
2. Wait until the boot-up process has been completed and for TunerStudio to be displayed
3. Plug-in Keyboard/Touchpad into computer
4. Connect to the Internet
» Click on the Network Symbol on the top-right of the Application Bar
» Click on the Wireless Network you would like to connect
» Enter Network Password
5. With your Keyboard/Touchpad click on:
» Help
» Enter Registration

e Enter in your TunerStudio MS/Ultra registration information

6. Close TunerStudio to save settings

. TunerStudio MS Lite! v3.0.28 - EFI Simplified

File Options Data Logging Communications Tools | Help

|‘ Gauge Cluster i Tuning & Dyno Views | Graphing & | TunerStudio Help E
Check For Update r
¥ Automatic Update Check '
Enter Registration
EF' Create TunerStudio Debug Package
—EA ‘ About
ANALYTICS —F
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Restoring TunerStudio Vehicle Project
The Digital Dash utilizes your current TunerStudio Vehicles Project, since it is running a full version of
TunerStudio. This will give you all the same features and dashboard options as your tuning laptop of
tuning, datalogging, and dashboard display. You will be able to make changes directly in the Digital Dash
removing the need for the laptop in the passenger seat.

Steps to complete on your Tuning Laptop:
1. The Digital Dash uses a different “Connection Type” to your MS ECU, so you will need to adjust this
in your Vehicle Project before restoring it to the Digital Dash:
» Open your Vehicle Project on your Tuning Laptop
» Click on:
e Communications Tab
e Settings
e Connection Type: Click on the drop-down list
e Select RS$232 Serial Interface
» Save the Vehicle Project
o RECOMMENDATION: Save it as a different filename
» CLOSE TunerStudio for the changes to save correctly to your project file
2. Insert the provided Thumb Drive into your tuning Laptop
Copy your Vehicle Project Folder to the Thumb Drive
4. Reopen TunerStudio and return your Vehicle Project’s Communication Type back to original setting
on your tuning Laptop
> WARNING: Failure to do so may cause a connection issue the next time to connect your tuning laptop

w

Steps to complete on your Digital Dash:

1. Turn ON the Ignition to the Vehicle to start the boot-up of the Digital Dash

2. Wait until the boot-up process has been completed and for TunerStudio to be displayed
3. Click on the TunerStudio Project folder icon at the top-left of the screen

TunerStudio
Projects

>
4. Plugin the Thumb Drive with your Vehicles Project

> Click “OK” to open the Thumb Drive file location when prompted
» Copy the Vehicle Project from the Thumb Drive to the TunerStudio Project Folder
> Close both TunerStudio Projects and Thumb Drive folders when done

Reminder to remove any thumb drive plugged from the Digital Dash
after uploading your Project File
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5. Click-on/Open TunerStudio back up
6. With your Keyboard/Touchpad click on:

> File
» Open Vehicle Project
» Select your Vehicle Project

L. TunerStudio MS Lite! v3.0.28 - EFI Simplified

File | Options Data Logging Communications Tools Help

Ctrl-N
Alt-O

New Project
Open Project
Import Project Backup

yno Views f Graphing & Logging

Tune Restore

Load Tune (msq) Ctrl-O

- ANALYTICS

Ll |

Exit

Enabling TunerStudio Start-up Features

After the boot-up process of the Digital Dash you would like to have your Dashboard auto display. To
enable this feature, you need to activate the Dashboard to Full-screen on Start-up option of TunerStudio.

1. With TunerStudio open from the previous step
2. With your Keyboard/Touchpad click on:

» Options

> Preferences

> Select the below (2) features:
e Load Last Project on Start-up
o Make Dashboards Full Screen

File | Options | Data Logging Communications Tools Help

/| Language 4 Fuel # |gnition ﬂ

| Look and Feel » Settings el Settings | & e ©
i;g Navigation » leed Loggers i Tune Analyze Live! - Tune For You [
[ View » ster [ Tuning & Dyno View!

Advanced 4

Preferences » ' Load Last Project on startup
Restore Points »| ¥ Make Dashboards Full Screen
Performance »| Settings Dialog Font Size

¥ Perform Difference Report On Connect

¥ Automatically Load and Save Current Tune

¥ Prompt if CurrentTune altered by other program
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Enable Dash Only Mode

To be able to utilize all the tuning features of TunerStudio you need to disable the Dash Only Mode. This
will give you the ability to have access to all your tune settings from your dash screen.

1. With TunerStudio open from the previous step
2. Use your Keyboard/Touchpad click on:
» Options
» Performance
e Check the checkbox for “Dash Only Mode”

File |Options Data Logging Communications Tools

Gau Language ’
Look and Feel *»

Navigation ’
View ’
Advanced ’

Preferences !

Restore Points »
Performance » ¥ Gauge Float down on start

¥ Dash Only Mode

Setup of the Communication Settings

Now its time to connect your Digital Dash to your MS ECU, so they are able to communicate/connect
together automatically. This process you will need to detect the which USB Port you have the MS ECU
USB plugged into.

1. Double-check you have the MS ECU plugged into one of the computer’s open USB Ports
2. With TunerStudio open from the previous step
3. Use your Keyboard/Touchpad click on:

» Communications

> Settings

File Options Data Logging | Communications| Tools Help

‘..:;f‘BasiclLoadH ﬁ Settings
| 75 Settings S Data Rate

" Diagnostics & High Speed L GPS Configuration
" Gauge Cluster Mini Terminal

[

[ =TI

=
™

o

Comm Debug Log

&, Megasquirt Baud Rate
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4. Communication Settings:
» Double-check your “Connection Type” is RS232 Serial Interface
> Click-on “Detect”

e Allow the computer to auto detect which USB Port you have the MS ECU Tuning Cable
plugged into

e Once detected click-on “Accept”
> Click-on “Accept” to close the Communication Settings window
® | Communication Settings X

Communication Settings

Connection Type

RS232 Serial Interface ~

Connection Settings

Com Port: ‘COM“ \" o
Baud Rate: }9500 l" 7}
L] Bluetooth Port @

Not tested Test Port Detect
Accept Cancel
>

5. Saving the above Communication Settings to your Vehicle Project
» Use your Keyboard/Touchpad click on:
o File
e Vehicle Projects
e Project Properties (Shortcut Ctrl+P)
o Once open click-on “Ok”

File | Options Data Logging Communications Tools Help

Vehicle Projects » New Project Ctrl-N
Recent Vehicle Projects * Open Project Alt-O
Tune Restore Points  CiR | Close Project Alt=X
Load Tune (msq) Ctrl-O | Create Project Backup
Save Tune Cirl-S | Import Project Backup

Save Tune As Project Properties

Compare Tune Ctrl-M
¥ Work Offline Ctrl-W
Exit

>
6. This will save your settings to your Vehicle Project

7. TunerStudio will now automatically close your Vehicle Project and Reopen
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Choosing of Dashboard

There are many already pre-programmed dashboards from TunerStudio and Digital Dash EFI to choose
from. You are also able to design your own dashboard or modify an existing dashboard as well.

1. With TunerStudio open; Right-Click on Dashboard
» Mouse over; then click on:
e Load / Save
e Load Dashboard

File Options Datalogging Communications Tools Help Search
© | 7y BasiciLoad Fuel # Ignition v ) Boost! | 7).~ 3D Tuning | g CAN
g
2 setings setiings || @ Settings [ # Srupiidie) G Accel Enrich Advanced || &> Maps busiTestmo
Diagnostics & High Speed Loggers rTune Analyze Live! - Tune For You | Notes
Gauge Cluster [ Tuning & Dyno Views [ Graphing & Logging |

Application Indicators | Save Dashboard

Reset Value
Background

™ Antialiasing Enabled
Full Screen

[1 Designer Mode

Gauge Demo

2. You can choose from preloaded TunerStudio or DD-EFI Dashboards
» Click-on the drop-down menu

£ Select Dashboard X
Select Dashboard

Default (88 Mustang 331) ~
[] Other ‘

Temp 160

116

268
degrees
S0

Ok H Cancel H Apply |
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Google Drive Sync Setup
This feature links your Google Drive Account to your Digital Dash allowing your Datalogs and Tune Files
to be automatically synced. There won’t be any need to copy/paste Datalogs to a Thumb Drive for
review along with auto updating your tune files back to your Digital Dash upon start-up.

DD-EFI-7-DDKIT Installation Manual

1. Open GDrive Installer — Click the Start Button (Raspberry Top-Left)

>
>

Go to DD-EFI Folder
Then GDrive Installer

2. Complete the Google Drive Sync Configuration — Type the below steps:

>

VVVYVYVYVYVVYYVYVYVVYVYYVYYVYYVY

n & Enter

DDEFI (All Caps) & Enter
12 & Enter

Enter

Enter

1 & Enter

Enter

Enter

n & Enter

y & Enter

Login to Google Account
Accept rclone

n & Enter

y & Enter

g & Enter

reboot & Enter

Remotely Accessing your Digital Dash — Any Desk

This feature gives you the ability for remote access to your Digital Dash, which can be utilize by your
remote tuner, crew chief, yourself, etc. You can then make changes to your dashboard and/or tune
from any computer.

1. Make sure the DD-EFI Digital Dash is ON

2. Wait for the Digital Dash to complete the boot-up sequence

3. Using your Wireless Keyboard & Mouse double-click to exit Fullscreen in TunerStudio

4. Click on the Any Desk Icon at the top-right of the screen ’)

5. Use the Any-Desk Address for Remote Connection

AnyDesk
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Modification of Boot-Up Splash Screen
During the boot-up of the Digital Dash a Splash Screen video is played the same as newer vehicles. The

Splash Screen video is user configurable to play any .MP4 format video, but needs to be a minimum of 25
seconds or longer.

1. Copy your new Splash Screen video on the provided Thumb Drive
» MAKE SURE:
e The video is a .MP4 file format
e The video needs to be a minimum of 25 seconds or longer
o The video filename is “splashscreen.mp4”
o Right-Click on video file
o Choose option Rename
o Rename file to: splashscreen.mp4

2. Turn ON the Ignition to the Vehicle to start the boot-up of the Digital Dash
3. Wait until the boot-up has been completed and your TunerStudio dashboard is displayed

4. With your Keyboard/Touchpad exit the Fullscreen of the Dashboard
» Keyboard - Esc Key
» Mouse - Double-Click on Dashboard

5. Open the Splashscreen video location:
» Click on the Start Button (Raspberry icon) on the Top Left of the screen
» Scroll to the DD EFI folder
> Scroll over and click on the Movie Icon

[=]

6. Plug-in to the computer’s USB Port the Thumb Drive with your new Splashscreen video
> You will receive an option to open the folder
» Click “OK”

7. Rename the current splashscreen.mp4 (This ensures you don’t overwrite this file)
» Right-click on splashscreen.mpa4 file
» Click Rename
» Rename the file (ie: DDEFI Splashscreen)

8. Drag your new Splashscreen video from your Thumb Drive to the Splashscreen folder

9. Make sure your new Splashscreen video is named correctly “splashscreen.mp4”
> Failure to get the file name correct the video will not play

10. Close the folders as you are completed
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